using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$";
string input = @"123
129
1
2
67
113
4095
4096
4099
402
4091
1021
1211
4032
4089
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}