#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+"
Local $sString = "3.1 Introduction" & @CRLF & _
"3 Battery" & @CRLF & _
"3.1\nIntroduction" & @CRLF & _
"" & @CRLF & _
"A1 Introduction" & @CRLF & _
"A1.1 String" & @CRLF & _
"B3 Battery Tests" & @CRLF & _
"I3.1 Etc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")