const regex = new RegExp('^[A-Z]?\\d+(?:\\.\\d+)?(?:\\s{1,10}|\\\\n)(?:[A-Z][a-z]+ ?)+', 'gm')
const str = `3.1 Introduction
3 Battery
3.1\\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}