// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+").unwrap();
let string = "3.1 Introduction
3 Battery
3.1\\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}