package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+`)
var str = `3.1 Introduction
3 Battery
3.1\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}