re = /^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+/m
str = '3.1 Introduction
3 Battery
3.1\\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end