import Foundation
let pattern = #"^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3.1 Introduction
3 Battery
3.1\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)