import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]?\\d+(?:\\.\\d+)?(?:\\s{1,10}|\\\\n)(?:[A-Z][a-z]+ ?)+";
final String string = "3.1 Introduction\n"
+ "3 Battery\n"
+ "3.1\\nIntroduction\n\n"
+ "A1 Introduction\n"
+ "A1.1 String\n"
+ "B3 Battery Tests\n"
+ "I3.1 Etc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}