#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")"
Local $sString = "{"secretWord1":"private", "something": "\"secretWord2\":\"privateToo\"", "ssecretWord1":"private", }"
Local $sSubst = "\1*****\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)