const regex = /(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\?"(secretword1|secretword2)\\\\?":\\\\?")(.*?)(\\\\?")', 'gi')
const str = `{"secretWord1":"private", "something": "\\"secretWord2\\":\\"privateToo\\"", "ssecretWord1":"private", }`;
const subst = `\1*****\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);