import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\?\"(secretword1|secretword2)\\\\?\":\\\\?\")(.*?)(\\\\?\")";
final String string = "{\"secretWord1\":\"private\", \"something\": \"\\\"secretWord2\\\":\\\"privateToo\\\"\", \"ssecretWord1\":\"private\", }";
final String subst = "\\1*****\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}