package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")`)
var str = `{"secretWord1":"private", "something": "\"secretWord2\":\"privateToo\"", "ssecretWord1":"private", }`
var substitution = "\1*****\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}