use strict;
my $str = '{"secretWord1":"private", "something": "\\"secretWord2\\":\\"privateToo\\"", "ssecretWord1":"private", }';
my $regex = qr/(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")/ip;
my $subst = '\\1*****\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";