$re = '/(\\\\?"(secretword1|secretword2)\\\\?":\\\\?")(.*?)(\\\\?")/i';
$str = '{"secretWord1":"private", "something": "\\"secretWord2\\":\\"privateToo\\"", "ssecretWord1":"private", }';
$subst = "\1*****\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;