using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\?""(secretword1|secretword2)\\?"":\\?"")(.*?)(\\?"")";
string substitution = @"\1*****\4";
string input = @"{""secretWord1"":""private"", ""something"": ""\""secretWord2\"":\""privateToo\"", ""ssecretWord1"":""private"", }";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}