import Foundation
let pattern = #"(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"{"secretWord1":"private", "something": "\"secretWord2\":\"privateToo\"", "ssecretWord1":"private", }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1*****\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)