// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(\\?"(secretword1|secretword2)\\?":\\?")(.*?)(\\?")"#).unwrap();
let string = "{\"secretWord1\":\"private\", \"something\": \"\\\"secretWord2\\\":\\\"privateToo\\\"\", \"ssecretWord1\":\"private\", }";
let substitution = "\\1*****\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}