# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+)-(\d+)\s+(.+)/$1\/$1-$2\/$3/g;t' <<< "alabala-1000 Intern"