use strict;
my $str = 'alabala-1000 Intern';
my $regex = qr/(.+)-(\d+)\s+(.+)/p;
my $subst = '$1/$1-$2/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";