import Foundation
let pattern = #"(.+)-(\d+)\s+(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"alabala-1000 Intern"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$1-$2/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)