using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)-(\d+)\s+(.+)";
string substitution = @"$1/$1-$2/$3";
string input = @"alabala-1000 Intern";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}