#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.+)-(\d+)\s+(.+)"
Local $sString = "alabala-1000 Intern"
Local $sSubst = "$1/$1-$2/$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)