$re = '/(.+)-(\d+)\s+(.+)/';
$str = 'alabala-1000 Intern';
$subst = "$1/$1-$2/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;