// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.+)-(\d+)\s+(.+)").unwrap();
let string = "alabala-1000 Intern";
let substitution = "$1/$1-$2/$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}