#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b\n\b"
Local $sString = "Paragraph1" & @CRLF & _
"" & @CRLF & _
"Paragraph2" & @CRLF & _
"Paragraph2" & @CRLF & _
"Paragraph2" & @CRLF & _
"Paragraph2" & @CRLF & _
"" & @CRLF & _
"Paragraph3" & @CRLF & _
"Paragraph3" & @CRLF & _
"" & @CRLF & _
"Paragraph4"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)