import re
regex = re.compile(r"\b\n\b", flags=re.MULTILINE)
test_str = ("Paragraph1\n\n"
"Paragraph2\n"
"Paragraph2\n"
"Paragraph2\n"
"Paragraph2\n\n"
"Paragraph3\n"
"Paragraph3\n\n"
"Paragraph4")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)