const regex = new RegExp('\\b\\n\\b', 'gm')
const str = `Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);