package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\n\b`)
var str = `Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}