$re = '/\b\n\b/m';
$str = 'Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;