re = /\b\n\b/m
str = 'Paragraph1
Paragraph2
Paragraph2
Paragraph2
Paragraph2
Paragraph3
Paragraph3
Paragraph4'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result