package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[ERROR\:.*?:program2`)
var str = `[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}