import re
regex = re.compile(r"\[ERROR\:.*?:program2", flags=re.MULTILINE)
test_str = ("[ERROR:location1:program1.34]\n"
"[ERROR:location10:program2.10]\n"
"[ERROR:location4:program2.45]\n"
"[ERROR:location9:program1.30]\n"
"[ERROR:location2:program2.60]\n"
"[INFO:location2:program2.60]\n"
"[WARN:location4:program2.45]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")