re = /\[ERROR\:.*?:program2/m
str = '[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end