// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[ERROR\:.*?:program2").unwrap();
let string = "[ERROR:location1:program1.34]
[ERROR:location10:program2.10]
[ERROR:location4:program2.45]
[ERROR:location9:program1.30]
[ERROR:location2:program2.60]
[INFO:location2:program2.60]
[WARN:location4:program2.45]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}