import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[ERROR\\:.*?:program2";
final String string = "[ERROR:location1:program1.34]\n"
+ "[ERROR:location10:program2.10]\n"
+ "[ERROR:location4:program2.45]\n"
+ "[ERROR:location9:program1.30]\n"
+ "[ERROR:location2:program2.60]\n"
+ "[INFO:location2:program2.60]\n"
+ "[WARN:location4:program2.45]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}