# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(CHAR \()(\) FOR BIT DATA)\((\d+)\)/$1$3$2/gm;t' <<< "CHAR () FOR BIT DATA(250) NOT NULL"