// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(CHAR \()(\) FOR BIT DATA)\((\d+)\)").unwrap();
let string = "CHAR () FOR BIT DATA(250) NOT NULL";
let substitution = "$1$3$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}