use strict;
my $str = 'CHAR () FOR BIT DATA(250) NOT NULL';
my $regex = qr/(CHAR \()(\) FOR BIT DATA)\((\d+)\)/mp;
my $subst = '$1$3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";