const regex = /(CHAR \()(\) FOR BIT DATA)\((\d+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(CHAR \\()(\\) FOR BIT DATA)\\((\\d+)\\)', 'gm')
const str = `CHAR () FOR BIT DATA(250) NOT NULL`;
const subst = `$1$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);