$re = '/(CHAR \()(\) FOR BIT DATA)\((\d+)\)/m';
$str = 'CHAR () FOR BIT DATA(250) NOT NULL';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;