using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(CHAR \()(\) FOR BIT DATA)\((\d+)\)";
string substitution = @"$1$3$2";
string input = @"CHAR () FOR BIT DATA(250) NOT NULL";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}