re = /(CHAR \()(\) FOR BIT DATA)\((\d+)\)/m
str = 'CHAR () FOR BIT DATA(250) NOT NULL'
subst = '$1$3$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result