#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(CHAR \()(\) FOR BIT DATA)\((\d+)\)"
Local $sString = "CHAR () FOR BIT DATA(250) NOT NULL"
Local $sSubst = "$1$3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)