# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(['"`]).*?\1(*SKIP)(*F)|\\n//g;t' <<< "\nnew\"test\naaaa\"\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n"