using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""`]).*?\1(*SKIP)(*F)|\\n";
string substitution = @"";
string input = @"\nnew""test\naaaa""\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}