#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(['"`]).*?\1(*SKIP)(*F)|\\n"
Local $sString = "\nnew"test\naaaa"\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)