import Foundation
let pattern = #"(['"`]).*?\1(*SKIP)(*F)|\\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\nnew"test\naaaa"\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)