use strict;
my $str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n\'this \\n should also be kept\'\\n';
my $regex = qr/(['"`]).*?\1(*SKIP)(*F)|\\n/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";