$re = '/([\'"`]).*?\1(*SKIP)(*F)|\\\\n/';
$str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n\'this \\n should also be kept\'\\n';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;