re = /(['"`]).*?\1(*SKIP)(*F)|\\n/
str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n\'this \\n should also be kept\'\\n'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result